Tutorial: How to Configure Metro E in 1941 Router?

Cisco 1941 router builds on the best-in-class offering of the existing Cisco 1841 Integrated Services Routers by offering 2 models-Cisco 1941 and Cisco 1941W. In addition to the support of a wide range of wireless and wired connectivity options supported on Cisco 1941 Series, Cisco 1941W offers integration of IEEE 802.11n access point which is backwards compatible with IEEE 802.11a/b/g access points.

All Cisco 1900 Series Integrated Services Routers offer embedded hardware encryption acceleration, optional firewall, intrusion prevention, and application services. In addition, the platforms support the industries widest range of wired and wireless connectivity options such as T1/E1, xDSL, 3G, and GE.

Back Panel of the Cisco 1941 and Cisco 1941W Router

Cisco 1941 router

How to configure Metro E in 1941 router

Now, let’s check a typical problem that Cisco 1941 & Cisco 1900 series users may have.

Q: I’m actually no idea on how to configure Metro E in 1941 router. May anyone of you guide me as I can’t find any from internet.

Below are my current network connections:-

Branch A LAN — Router A — Router B — Branch B LAN Keith Liew

A: You will need to find out if the service provider is transporting your frames at layer 2, or if you must point to their router.  You will also want to find out if they have hard coded speed an duplex.  You will definitely want that to match.  Once you find out the speed and duplex, the configuration should be set appropriately for that.  Then if the service provider is doing a layer two solution for you, the configuration would be exactly the same as if you hooked the routers up back to back in a lab.  If they are doing a layer 3 solution, you will need IP addresses that correspond with theirs’ and point your routers to their IP addresses.

Q: I asked the questions below and ISP replied. Wonder if my configuration of my router correct? Please advice

1) Service provider is transporting the frames at layer 2? Or Layer 3?–layer 2

2) Must we configure to point to your router?–at your router, just set as access port and configure with WAN IP address

3) Hard coded speed and duplex?–Nilai site with auto-nego, no hard coded; Shah Alam site is hard coded with full duplex & speed 100

If are doing a layer 3 solution, please provide IP addresses that correspond with your router.–N/A

SaToNilai#show startup-config

Using 1197 out of 262136 bytes

!

! Last configuration change at 09:21:06 UTC Thu Jun 9 2011

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SaToNilai

!

boot-start-marker

boot-end-marker

!

enable secret 5

enable password

!

no aaa new-model

!

no ipv6 cef

ip source-route

no ip routing

no ip cef

!

!

!

!

multilink bundle-name authenticated

!

!

!

license udi pid CISCO1941/K9 sn

!

!

!

!

!

!

!

!

interface GigabitEthernet0/0

description LAN Connection

ip address 10.110.125.3 255.255.252.0

no ip route-cache

duplex auto

speed auto

no mop enabled

!

interface GigabitEthernet0/1

description MetroE Connection

ip address 192.168.168.1 255.255.255.252

no ip route-cache

duplex full

speed 100

!

ip default-gateway 10.110.125.1

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 10.111.44.0 255.255.255.0 192.168.168.2

ip route 172.1.48.0 255.255.252.0 192.168.168.2

!

!

!

snmp-server community Sa RO

!

control-plane

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password

logging synchronous

login

!

scheduler allocate 20000 1000

end

SaToNilai#

Re1: From “SaToNilai”, can you ping 192.168.168.2.  If not, confirm that 192.168.168.2 is on your Nilai router and that it is “UP/UP”.  Keep in mind that this router will only deliver packets to 172.1.48.0-172.1.51.255 and 10.111.44.x based on the static routes.

Re2: Are you running Metro-E yourself? Or through an SP?

If you are going through an SP, then there’s really nothing special for you to do.  The CE side of things is a generic Ethernet configuration.  You’ll need to match whatever’s on the other side.  So both sides (CE) would be a single IP on the 192.168.168.x/30 network (.1 on one branch CE, .2 on the other) and everything else from your SP should be transparent.

Reply from Keith to Re2:

The CE side of things is a generic Ethernet configuration.  You’ll need to match whatever’s on the other side.  So both sides (CE) would be a single IP on the 192.168.168.x/30 network (.1 on one branch CE, .2 on the other) and everything else from your SP should be transparent.

You’ll need to match whatever’s on the other side – is this talking about the SP side? example: Site A SP hard coded Full duplex and 100. Site B SP has no hard coded. So, i’m configuring site A router to have full duplex and 100 and Site B with duplex auto and speed auto. Am I right?

More Related: Details of Cisco 1941 Series Integrated Services Routers & Cisco 1900 Series Routers from cisco.com

Popular Cisco 1900 items’ name:

CISCO1941/K9, CISCO1941W-A/K9, CISCO1941W-E/K9, CISCO1941W-P/K9, CISCO1941W-N/K9, CISCO1941W-C/K9

Share This Post

Post Comment