How to Troubleshoot OSPFv3 Frame-Relay?

Open Shortest Path First (OSPFv3) is a link state protocol that supports IPv6 and as well as IPv4. OSPF version 3 differs from OSPF version 2 for IPv4 as some changes have been incorporated to facilitate IPv6.

This article demonstrates how to troubleshoot OSPFv3 fail to form neighbor adjacency when configured using Frame-Relay. The OSPFv3 uses Link-local address to form neighbor adjacency by sending and receiving the hello packet to the neighbor router. While configuring OSPFv3 using Frame-Relay one should remember the difference that the DLCI mapping should be done for the Link-local addresses. The OSPFv3 neighbor adjacency will not be formed, until their link-local addresses are mapped to the appropriate DLCI’s.

Note: Prerequisite: It is assumed that the reader has an understanding of OSPFv3 and Frame-Relay.

Background Information

The two routers (R1and R2 ) in the network diagram are connected to a frame-relay switch via serial interfaces communicate with each other using OSPFv3.The routers are configured with loopbacks and OSPFv3 is advertised on each interface using the command ipv6 ospf <process id> area <area id>.

Topology Diagram

ospfv3 frame-relay

Configuration

Note: All configurations are tested on Cisco 7200 Router running IOS 15.0(1) M5 software.

Router R1 Router R2
R1#show runBuilding configuration…

!

version 15.0

!

hostname R1

!

ipv6 unicast-routing

ipv6 cef

!

interface Loopback0

no ip address

ipv6 address AA00::1/128

ipv6 ospf 1 area 0

!

interface Loopback1

no ip address

ipv6 address AA01::1/128

ipv6 ospf 1 area 0

!

interface Serial1/0

no ip address

encapsulation frame-relay

ipv6 address 1011:1:1:1::11/64

ipv6 ospf network broadcast

ipv6 ospf 1 area 0

serial restart-delay 0

frame-relay map ipv6 1011:1:1:1::12 101 broadcast

!

ipv6 router ospf 1

router-id 1.1.1.1

log-adjacency-changes

!

!

end

R2#show runBuilding configuration…

!

version 15.0

!

hostname R2

!

ipv6 unicast-routing

ipv6 cef

!

interface Loopback0

no ip address

ipv6 address BB00::1/128

ipv6 ospf 1 area 0

!

interface Loopback1

no ip address

ipv6 address BB01::1/128

ipv6 ospf 1 area 0

!

interface Serial1/0

no ip address

encapsulation frame-relay

ipv6 address 1011:1:1:1::12/64

ipv6 ospf network broadcast

ipv6 ospf 1 area 0

serial restart-delay 0

frame-relay map ipv6 1011:1:1:1::11 202 broadcast

!

!

ipv6 router ospf 1

router-id 2.2.2.2

log-adjacency-changes

!

!

end

Problem

In the above configuration, the frame-relay DLCI mapping is done to the IPv6 global address. To verify the ospfv3 neighbor adjacency uses the command show ipv6 ospf neighbor in router R1.

show ipv6 ospf nei updated

The above output shows that the hellos are being sent and received the OSPF peers and DR/BDR election has happened but still the routers are in EXSTART state.

Using debug commands, debug ipv6 ospf adj  and debug ipv6 ospf hello debug the adjacency events and hello events.

debug ipv6 ospf-updated

The above debug output confirms that the hellos are being sent and received by OSPFv3 peers. R1 send the DBD database description packets to router R2 but never receives acknowledgement.The EXSTART state indicates that the DR/BDR election has happened and initial DBD packet is sent.

Resolution

The reason is OSPFv3 uses link-local address to exchange packets as its shown in the above debug output.The DLCI mappings has to change to fix this issue. The frame-relay mappings have to be done for the link-local address of the neighbor router. The DLCI mappings are changed in the serial interface S1/0 on both the routers R1 and R2 as shown below:

config change-updated

You can see that as soon the DLCI mapping is done correctly to the link-local address of the neighbor, the OSPFv3 neighbor adjacency is formed between the routers R1 and R2.

Verify

To verify the the routers receives the routes via OSPFv3 use the command show ipv6 route ospf

show ipv6 route ospf

The above output shows that the routes are successfully received by both routers R1 and R2.

—Original DOC From https://supportforums.cisco.com/docs/DOC-25488 

References

Implementing OSPFv3

Cisco IOS IPv6 Command References

Sample Configuration for OSPFv3

More Related Cisco Tech Tips:

Conditional Route Origination in OSPF Domain

How to Use OSPF Point-to-Multi-Point on Ethernet?

Basic HSRP Configuration Example On Cisco IOS XR

Conditional Route Origination in OSPF Domain

How to Configure Cisco Routers as Frame Relay Switch (FRS)?

Share This Post

Post Comment