Eight Commands on a Cisco ASA Security Appliance You Should Know

2023 SEASON SALE Networking and Security Showcase In-stock ICT products at exclusive discounts

Eight commands on Cisco ASA security appliance you should know first. There are literally thousands of commands and sub-commands available to configure a Cisco security appliance. However, there are just a few commands required to configure basic functionality on the appliance.  Basic functionality is defined as allowing inside hosts to access outside hosts, but not allowing outside hosts to access the inside hosts.  Additionally, management must be allowed from at least one inside host.  To enable basic functionality, there are eight basic commands (these commands are based on software version 8.3(1) or greater):

  • interface
  • nameif
  • security-level
  • ip address
  • switchport access
  • object network
  • nat
  • route

 

Interface

The interface command identifies either the hardware interface or the Switch Virtual Interface (VLAN interface) that will be configured.  Once in interface configuration mode, you can assign physical interfaces to switchports and enable them (turn them on) or you can assign names and security levels to VLAN interfaces.

 

Nameif

The nameif command gives the interface a name and assigns a security level.  Typical names are outside, inside, or DMZ.

 

Security-level

Security levels are numeric values, ranging from 0 to 100, used by the appliance to control traffic flow.  Traffic is permitted to flow from interfaces with higher security levels to interfaces with lower security levels, but not the other way.  Access-lists must be used to permit traffic to flow from lower security levels to higher security levels.  The default security level for an outside interface is 0.  For an inside interface, the default security level is 100.  In the following sample configuration, the interface command is first used to name the inside and outside VLAN interfaces, then the DMZ interface is named and a security level of 50 is assigned to it.

ciscoasa(config)# interface vlan1
ciscoasa(config-if)# nameif inside
INFO: Security level for “inside” set to 100 by default.
ciscoasa(config-if)# interface vlan2
ciscoasa(config-if)# nameif outside
INFO: Security level for “outside” set to 0 by default.
ciscoasa(config-if)# interface vlan3
ciscoasa(config-if)# nameif dmz
ciscoasa(config-if)# security-level 50

IP Address

The ip address command assigns an IP address to a VLAN interface either statically or by making it a DHCP client.  With modern versions of security appliance software, it is not necessary to explicitly configure default subnet masks.  If you are using non-standard masks, you must explicitly configure the mask, otherwise, it is not necessary.

In the following sample configuration, an IP address is assigned to VLAN 1, the inside interface.
ciscoasa(config-if)# interface vlan 1
ciscoasa(config-if)# ip address 192.168.1.1

Switch-port Access

The switch port access command on the ASA 5505 security appliance assigns a physical interface to a logical (VLAN) interface.  In the next example, the interface command is used to identify physical interfaces, assign them to switch ports on the appliance, and enable them (turn them on).

This command is not used on the ASA 55×0 appliances.

ciscoasa(config-if)# interface ethernet 0/0
ciscoasa(config-if)# switchport access vlan 2
ciscoasa(config-if)# no shutdown
ciscoasa(config-if)# interface ethernet 0/1
ciscoasa(config-if)# switchport access vlan 1
ciscoasa(config-if)# no shutdown

 

Object Network Obj_any

The object network obj_any statement creates an object called “obj_any”.  (You do not have to name the object “obj_any”; that is a descriptive name, but you could just as easily name it “Juan”.)  The network option states that this particular object will be based on IP addresses.  The subnet 0.0.0.0 0.0.0.0 command states that obj_any will affect any IP address not configured on any other object.
ciscoasa(config-if)#object network obj_any
ciscoasa(config-network-object)#subnet 0.0.0.0 0.0.0.0

 

Nat

The nat statement, as shown below, tells the firewall to allow all traffic flowing from the inside to the outside interface  to use whatever address is dynamically (DHCP) configured on the outside interface.

ciscoasa(config)#nat (inside,outside) dynamic interface

 

Route

The route command, in its most basic form, assigns a default route for traffic, typically to an ISP’s router.  It can also be used in conjunction with access-lists to send specific types of traffic to specific hosts on specific subnets.

In this sample configuration, the route command is used to configure a default route to the ISP’s router at 12.3.4.6.  The two zeroes before the ISP’s router address are shorthand for an IP address of 0.0.0.0 and a mask of 0.0.0.0.  The statement outside identifies the interface through which traffic will flow to reach the default route.
ciscoasa(config-if)# route outside 0 0 12.3.4.6

The above commands create a very basic firewall, however, using a sophisticated device such as a Cisco PIX or ASA security appliance to perform such basic firewall functions is overkill.

Other commands to use include hostname to identify the firewall, telnet or SSH to allow remote administration, DHCPD commands to allow the firewall to assign IP addresses to inside hosts, and static route and access-list commands to allow internal hosts such as DMZ Web servers or DMZ mail servers to be accessible to Internet hosts.

Here is a sample base configuration:

Sample Base Configuration

ciscoasa(config)# interface vlan1
ciscoasa(config-if)# nameif inside
INFO: Security level for “inside” set to 100 by default.
ciscoasa(config-if)# interface vlan2
ciscoasa(config-if)# nameif outside
INFO: Security level for “outside” set to 0 by default.
ciscoasa(config-if)# interface ethernet 0/0
ciscoasa(config-if)# switchport access vlan 2
ciscoasa(config-if)# no shutdown
ciscoasa(config-if)# interface ethernet 0/1
ciscoasa(config-if)# switchport access vlan 1
ciscoasa(config-if)# no shutdown
ciscoasa(config-if)# interface vlan 2
ciscoasa(config-if)# ip address 12.3.4.5
ciscoasa(config-if)# interface vlan 1
ciscoasa(config-if)# ip address 192.168.1.1
ciscoasa(config-if)# route outside 0 0 12.3.4.6
ciscoasa(config-if)#object network obj_any
ciscoasa(config-network-object)#subnet 0.0.0.0 0.0.0.0
ciscoasa(config)#nat (inside,outside) dynamic interface
ciscoasa(config)#exit

—Original reading from networkworld.com

Excerpted from The Accidental Administrator:  Cisco ASA Security Appliance: A Step-by-Step Configuration Guide by Don R. CrawleyCisco ASA Security Appliance

Note: The Accidental Administrator: Cisco ASA Step-by-Step Configuration Guide is packed with 56 easy-to-follow hands-on exercises to help you build a working firewall configuration from scratch.  Based on software version 8.3(1), it’s the most straight-forward approach to learning how to configure the Cisco ASA Security Appliance, filled with practical tips and secrets learned from years of teaching and consulting on the ASA.

There is no time wasted on boring theory. The essentials are covered in chapters on installing, backups and restores, remote administration, VPNs, DMZs, usernames, transparent mode, static NAT, port address translation, access lists, DHCP, password recovery, logon banners, AAA (authentication, authorization, and accounting), filtering content, and more.

Here’s what you’ll find:

  • How to backup and restore software images and configurations
  • How to configure four different types of VPNs
  • The secrets to successfully building and implementing access-lists

All this information is presented in a straightforward style that you can understand and use right away. The idea is for you to be able to sit down with your ASA and build a working configuration in a matter of minutes. Of course, some of the more advanced configs may take a little longer, but even so, you’ll be able to “get it done” in a minimal amount of time!

More Cisco ASA Info and Tips:

VLAN Sub-Interfaces on Cisco ASA 5500 Firewall Configuration

Cisco ASA Firewall Licensing

How to Configure Cisco ASA 5505 Firewall?

How to Configure Cisco PIX Firewall?

Share This Post

Post Comment